環境
NICが2つあるサーバにRHEL7を導入し、NIC1に172.16.20.1/24、NIC2に172.16.20.10/24を割り当てました。

状況
別PCから172.16.20.10にPINGを定期的にうっていた所、数時間後にタイムアウトが発生するようになってしまった。
通信不能になった後、systemctl restart networkを行うと、PINGが通るようになり、数時間後にPINGが通らなくなる。

試行
同じネットワークに別NICでIPを割り振っていたのが原因で、NIC1に両方のIPを割り当てたら解決。

質問
何故、数時間は通信できて数時間後に通信不可になったのか。
既に問題解決して検証できる環境はないのですが、原因がきになるので、わかる方、教えていただけませんでしょうか。
また、環境があれば、短時間で検証できるような設定があるのでしょうか。
※数時間後にエラーになっていましたが、10分程度で再現するような設定など。

よろしくお願いします